Come Calcolare gli Interessi Legali con OpenOffice

Questa guida illustra passo per passo il procedimento per costruire un modello di foglio di calcolo con il quale determinare l’importo degli interessi legali maturati su una determinata somma in un periodo compreso tra due date; una volta costruito, il modello potrà essere aggiornato con estrema facilità.

Creiamo un nuovo foglio di calcolo. Iniziamo ad inserire le intestazioni: per ognuna spiegherò cosa sarà contenuto nella relativa colonna. “Data iniziale”: la data iniziale da cui maturano gli interessi; “Data finale”: la data in cui termina il periodo di maturazione degli interessi; “Capitale”: il capitale sul quale effettuare il calcolo; “Inizio intervallo”: l’inizio dell’intervallo di tempo in cui è in vigore un certo tasso legale; “Fine intervallo”: la fine dell’intervallo di cui sopra; “Tasso legale”: il tasso in vigore nell’intervallo di tempo individuato dalle due informazioni precedenti; “Data iniziale > Fine intervallo o Data finale < Inizio intervallo”: per scrivere questa intestazione su due righe, basta posizionarsi all’interno della cella e, nel punto in cui si vuole andare a capo, premere CTRL e Invio; la colonna conterrà un valore logico (vero o falso) per indicare che il periodo di calcolo non si sovrappone con l’intervallo di tempo considerato. “Data iniziale >= Inizio intervallo”: anche qui avremo un valore logico che specifica se l’intervallo di tempo considerato contiene la data in cui iniziano a maturare gli interessi; “Data finale <= Fine intervallo”: valore logico che specifica se l’intervallo di tempo considerato contiene la data in cui finiscono di maturare gli interessi; “H e I”: valore logico che indica se il periodo di calcolo degli interessi è interno ad un solo intervallo; “H – I”: poiché il valore vero corrisponde a 1 e il valore falso corrisponde a 0, questa operazione ci fornisce un risultato utile poi per controllare di volta in volta il verificarsi delle condizioni poste sulle due date (Data iniziale >= Inizio intervallo e Data finale <= Fine intervallo); infatti, se si verifica la prima e non la seconda (cioè è stato trovato l’intervallo a cui appartiene la data iniziale) avremo H-I=1, se si verifica la seconda e non la prima (cioè è stato trovato l’intervallo a cui appartiene la data finale), avremo H-I=-1, se si sono verificate entrambe (il periodo di calcolo degli interessi è interno ad un solo intervallo) oppure non si è verificata nessuna delle due (l’intervallo considerato è interno al periodo di calcolo degli interessi) avremo H-I=0; Giorni = il numero di giorni da considerare per il calcolo degli interessi, per ogni intervallo; Interessi = la quota di interessi sul capitale relativa ad ogni intervallo. Formattiamo le colonne (tasto sinistro del mouse sulla intestazione, poi tasto destro, selezionando dal menù contestuale la voce “Formatta celle” e poi scegliendo la scheda “Numeri”): Colonne A (Data iniziale), B (Data finale), D (Inizio intervallo), E (Fine intervallo): categoria “Data”, formato “31/12/1999”. Colonne C (Capitale), M (Interessi): si può optare per la categoria “Numero” oppure “Valuta”, facendo attenzione a scegliere l’opzione con due cifre decimali. Per le altre colonne può andar bene la categoria “Numero”, formato “Standard”. Adesso passiamo ad inserire i valori e le formule di partenza: Lasciamo una riga in bianco e partiamo dalla n. 3: Nelle celle A3 e B3 scriviamo rispettivamente la data di partenza e quella finale per il calcolo degli interessi; in C3 indichiamo invece il capitale. Dalla cella D3 alla D13 e dalla cella E3 alla E12 inseriamo gli intervalli di validità dei vari tassi legali, ponendo nelle celle dalla F3 alla F13 i tassi stessi; poiché l’ultimo tasso è quello in vigore, nella cella E13 inseriremo la formula =OGGI(), che restituisce il giorno corrente. Ora le formule per il calcolo: In G3 (Data iniziale >Fine intervallo o Data finale < Inizio intervallo) scriviamo: =O(ANNO(B$3)<ANNO(D3);ANNO(A$3)>ANNO(E3) Quindi copiamo la formula nelle celle sottostanti, dalla G4 alla G13: ricordo che basta selezionare la cella che si vuole copiare, posizionarsi con il mouse sull’angolo in basso a destra (dove si vede un quadratino nero; il puntatore del mouse prenderà la forma di una crocetta) e, con il tasto sinistro premuto, trascinare il mouse in basso: man mano che si procede il contorno delle celle incluse diventerà rosso.

Per ognuna delle seguenti formule ripeteremo il processo di copia nelle celle sottostanti, dalla riga 4 alla riga 13: H3 (Data iniziale>= Inizio intervallo) inseriamo: =ANNO(A$3)>=ANNO(D3); I3 (Data finale <= Fine intervallo): =ANNO(B$3)<=ANNO(E3); J3(H e I): =E(H3;I3); K3(H-I): =H3-I3; L3(Giorni): =SE(G3=1;0;SE(K3=1;GIORNI(E3;A$3); SE(K3=-1;GIORNI(B$3;D3);SE(J3=1;GIORNI(B$3;A$3);GIORNI(E3;D3) (N.B: La formula va scritta su un’unica riga.); M3 (Interessi): =C$3*L3*F3/36500 Infine in M14 inseriremo la formula per sommare gli interessi calcolati per ogni intervallo: =SOMMA(M3:M13).

Per finire, ricordiamo il significato e l’effetto delle formule usate. ANNO() restituisce il valore dell’anno presente in una data; O() calcola la disgiunzione logica tra i suoi argomenti (il risultato sarà vero se almeno uno degli argomenti è vero); E() calcola la congiunzione logica (risultato vero solo se gli argomenti sono tutti veri); GIORNI() determina il numero di giorni intercorrenti tra due date (quella successiva si indica per prima); SE(test; risultato se test vero; risultato altrimenti): esegue il test e, in base al risultato, procede con una delle due possibili alternative divise dal “;”. Il simbolo $ serve a far sì che, quando si copia una formula, il riferimento ad una cella (oppure ad una riga o ad una colonna) non cambi.

Adesso potrete salvare il vostro lavoro: per evitare che le formule possano dare problemi dovuti alla mancata compatibilità con altri programmi, è opportuno scegliere il salvataggio come modello di foglio elettronico (estensione ots): questo ci consentirà di lavorare sempre su una copia creata automaticamente al momento dell’apertura del file, che poi salveremo normalmente, senza modificare il foglio di calcolo originale.

Lascia un commento

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *